Config dropdown menu shortcut bug references wrong project

Hi there! Just wanted to report a quick bug I noticed several weeks ago. I used to be able to quickly swap between config by clicking on the search bar and clicking a different config but as of a couple weeks ago, the options to select a relevant config for the project I’m currently in is out of sync.

For example, in this image, I’m currently in the prd config for my tls project and from the dropdown menu I expect to be able to click the dev config and be routed to the dev tls config. However as you can see, the href is actually pointing towards my database dev config.

This used to work like a charm up until a few weeks ago. Thought I’d pass along :slight_smile:

Here’s a screenshot for evidence, take a look at my current url for the selected project/config and at the bottom you can see the href of the dev option I’m hovering over.

Hi @uncvrd!

I was able to reproduce this. What appears to be happening is the first project you open is having its configs cached for the search. Then each subsequent project you view displays the configs for the first project. If you reload the page, it shows the correct configs. We’re looking into what’s causing this. I’ll post again when I have more information.


@uncvrd It looks like the underlying issue here involves a change we made to the secrets page that’s causing the search context to not reload on navigation. We have an open issue for it, but unfortunately, we have other issues that are higher priority right now, so it may take us some time to get that fixed. Sorry about that!

1 Like

Glad you were able to reproduce and submit a ticket for it. No worries on priority but happy it’s tracked. Thanks!

Hi @watsonian! Any updates from the engineering team about this bug?

@Grraahaam Unfortunately not. We were discussing this issue just the other day though. There are multiple layers to this problem – some of which we should be able to fix relatively easily, but there are other aspects that will involve a little more planning. Still not sure when exactly we might see a fix out for it currently.

@uncvrd @Grraahaam We shipped a fix that I believe has solved this. Could you double-check to see if what you were seeing is solved for you now?

1 Like

So far the bug doesnt appear any longer on my side after the few tests I’ve made! Well done! :v: