CLI Login "Please log in with Google

I am trying to follow the instructions at GitHub - DopplerHQ/python-doppler-env: Automatically inject Doppler secrets as environment variables for use during local development. When I run
doppler setup
I am asked if I want to open the browser. I copy and paste the authorization code into the browser form, and then I am presented with a message “Please log in with Google”

I am thoroughly confused by this, so if anyone can possibly point me in the right direction, I’d really appreciate it.


I figured it out. I think there was a difference in the web login interface between Chrome and Firefox on my machine. When I switched to Chrome, it worked fine. Not sure if that’s an issue with Firefox, or if it’s a plugin I am using within Firefox.

Hi Bruce,

I wasn’t able to reproduce in Firefox 95.0.2 so I’m going to presume it’s related to an installed extension.

Thanks for reporting though!

I am still getting “Please Login to Google” from a windows system, when I do a PS> doppler login, and answer “Y” to use browser (I am using Chrome), I put in my Doppler account password: and I get a red error message “Please Login to Google”, weird. There is no area for account/username, simply password … and I did not set up with a Google integrated login on I set up my account using my own corporate email and password. So why is “Log in to Google” coming up?

Hi Ryan,

Thanks for the reply. I’ll try again with extensions off and report back.


Hi all!

This was related to a bug in our re-auth flow that was discovered and fixed yesterday, so you shouldn’t be encountering this problem anymore! If you still are, let me know and I can take a look at what may be going on.