Integration not working for vercel pro team with multiple projects

I have a vercel pro team that has multiple projects. One of them is already connected to doppler. When I try to add another project under the same team, the integration menu only shows me the project that is already integrated with doppler.

How can I resolve this?

Hi @Simon_Berens!

Welcome to the Doppler Community!

When you first connect the Vercel integration, it takes you through a setup process where you choose the permissions it has. As part of that process, you choose which account (personal or team) it’s for and which projects (you have the option to choose All Projects or Selected Projects). If you’re not seeing new projects you’re adding, my guess here is that you didn’t choose the “All Projects” option.

My recommendation is to try setting the integration up from scratch again:

  1. Remove the Vercel sync from any Doppler projects you’ve added it to.
  2. Remove the Doppler integration from Vercel by going to the integrations page, clicking the Manage link to the right of the Doppler integration, scroll to the bottom of the next page, and finally click the red Remove Integration button.
  3. Go to the Doppler workplace settings page (click the Settings link in the left sidebar) and scroll down to the Integrations section. Click the three dot menu on the right of the Vercel integration and click Disconnect.

After doing all that, try adding the Vercel sync again. This time when it walks you through the setup process, make sure you choose the All Projects option.

Let me know if that helps!


Thanks! That seems to have worked.

By the way, when doppler gives me a list of connections to choose from, it seems that that list never gets cleaned up, so I have a bunch of connections with the same name but I’m not sure which ones actually work. Is there a way to clean them up?

@Simon_Berens The connections are all in the workplace Settings page in the Integrations section. You can remove any unneeded ones by clicking the three dot menu next to one and choosing Disconnect. That should remove them from the list you see when creating a new sync.