# Unable to run any commands without --no-dns-resolver flag

**URL:** <https://community.doppler.com/t/unable-to-run-any-commands-without-no-dns-resolver-flag/261>\
**Category:** Need Help\
**Created:** [July 19, 2021, 3:33pm UTC](https://community.doppler.com/t/unable-to-run-any-commands-without-no-dns-resolver-flag/261 "2021-07-19T15:33:01Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![lotap](https://avatars.discourse-cdn.com/v4/letter/l/7ea924/32.png) [@lotap](https://community.doppler.com/u/lotap)\
**Post date:** [July 19, 2021, 3:33pm UTC](https://community.doppler.com/t/unable-to-run-any-commands-without-no-dns-resolver-flag/261/1 "2021-07-19T15:33:01Z")

</div>

Using debug here is the code I see:

```auto
Debug: Using custom DNS resolver 1.1.1.1:53
Debug: Get "https://api.doppler.com/v3/auth/cli/generate?arch=64-bit&hostname=Helios&os=linux&version=v3.30.1": context deadline exceeded (Client.Timeout exceeded while awaiting headers)
Debug: Get "https://api.doppler.com/v3/auth/cli/generate?arch=64-bit&hostname=Helios&os=linux&version=v3.30.1": context deadline exceeded (Client.Timeout exceeded while awaiting headers)

```

I have tried on windows using WSL2 as well as on a mac where I get pretty much the same error.

I have tried updating my router’s DNS to Google’s DNS servers and get the same error.

The only thing that works is using a VPN on windows. (The same VPN doesn’t work on mac)

My ISP is centurylink

---

<div class="post-metadata">

**Author:** ![ryan-blunden](https://sea2.discourse-cdn.com/flex016/user_avatar/community.doppler.com/ryan-blunden/32/9_2.png) [@ryan-blunden](https://community.doppler.com/u/ryan-blunden)\
**Post date:** [July 19, 2021, 9:29pm UTC](https://community.doppler.com/t/unable-to-run-any-commands-without-no-dns-resolver-flag/261/3 "2021-07-19T21:29:52Z")

</div>

Thanks for the info @lotap.

Our engineers are investigating this issue and for now, you can add the `--no-dns-resolver` flag which bypasses the internal DNS resolver that uses `1.1.1.1:53`.

You can also disable the DNS resolver for all requests by setting the following environment variable:

```auto
export DOPPLER_DISABLE_DNS_RESOLVER="true"

```

---

<div class="post-metadata">

**Author:** ![ryan-blunden](https://sea2.discourse-cdn.com/flex016/user_avatar/community.doppler.com/ryan-blunden/32/9_2.png) [@ryan-blunden](https://community.doppler.com/u/ryan-blunden)\
**Post date:** [July 22, 2021, 1:31am UTC](https://community.doppler.com/t/unable-to-run-any-commands-without-no-dns-resolver-flag/261/4 "2021-07-22T01:31:08Z")

</div>

Hi @lotap,

Wanted to let you know that we’ve just released CLI version v3.31.0 which disables our custom DNS resolver by default, meaning the `--no-dns-resolver` flag or `DOPPLER_DISABLE_DNS_RESOLVER` environment variable is no longer necessary.
